Collegamento LACP tra due MX960 Juniper e due Nexus Cisco in FabricPath domain:

 

lacp vpc mx960 nexus fabricpath

 

MX960-1:

 

set interfaces ae2 description "vPC multi-chassis to Nexus"

set interfaces ae2 flexible-vlan-tagging

set interfaces ae2 encapsulation flexible-ethernet-services

set interfaces ae2 aggregated-ether-options link-speed 10g

set interfaces ae2 aggregated-ether-options lacp active

!

set interfaces xe-1/1/0 gigether-options 802.3ad ae2

set interfaces xe-3/1/0 gigether-options 802.3ad ae2

 

MX960-2:

 

set interfaces ae3 description "vPC multi-chassis to Nexus"

set interfaces ae3 flexible-vlan-tagging

set interfaces ae3 encapsulation flexible-ethernet-services

set interfaces ae3 aggregated-ether-options link-speed 10g

set interfaces ae3 aggregated-ether-options lacp active

!

set interfaces xe-1/1/0 gigether-options 802.3ad ae3

set interfaces xe-3/1/0 gigether-options 802.3ad ae3

 

 

NEXUS-1:

 

fabricpath domain default

!

install feature-set fabricpath

feature-set fabricpath

!

cfs eth distribute # cisco fabric services

feature interface-vlan

feature lacp

feature vpc

feature lldp

feature vtp

feature fex

!

vtp mode transparent

!

spanning-tree vlan < range value vlan-id > priority 8192 (n.b. tutte le vlan debbono avere lo stesso valore di priority)

!

vpc domain 1

  role priority 1

  peer-keepalive destination a.b.c.x source a.b.c.y

  peer-gateway

  fabricpath switch-id 1

!

interface port-channel1

  description peer-link

  switchport mode fabricpath

  vpc peer-link

!

interface port-channel2

  description to MX960-01

  switchport mode trunk

  switchport trunk allowed < range value vlan-id

  vpc 2

!

interface port-channel3

  description to MX960-02

  switchport mode trunk

  switchport trunk allowed vlan < range value vlan-id

  vpc 3

!

interface Ethernet1/1

  description to MX960-01

  switchport mode trunk

  switchport trunk allowed vlan < range value vlan-id

  channel-group 2 mode active

!

interface Ethernet1/2

  description to MX960-02

  switchport mode trunk

  switchport trunk allowed vlan < range value vlan-id

 channel-group 3 mode active

!

interface Ethernet1/47

  description B2B Nexus-2

  switchport mode fabricpath

  channel-group 1 mode active

!

interface Ethernet1/48

  description B2B Nexus-2

  switchport mode fabricpath

  channel-group 1 mode active

 

 

 

NEXUS-2:

 

fabricpath domain default

!

install feature-set fabricpath

feature-set fabricpath

!

cfs eth distribute à (CISCO FABRIC SERVICES)

feature interface-vlan

feature lacp

feature vpc

feature lldp

feature vtp

feature fex

!

vtp mode transparent

!

spanning-tree vlan < range value vlan-id > priority 8192 (n.b. tutte le vlan debbono avere lo stesso valore di priority)

!

vpc domain 1

  role priority 1

  peer-keepalive destination a.b.c.y source a.b.c.x

  peer-gateway

  fabricpath switch-id 1

!

interface port-channel1

  description peer-link

  switchport mode fabricpath

  vpc peer-link

!

interface port-channel2

  description to MX960-01

  switchport mode trunk

  switchport trunk allowed < range value vlan-id

  vpc 2

!

interface port-channel3

  description to MX960-02

  switchport mode trunk

  switchport trunk allowed vlan < range value vlan-id

  vpc 3

!

interface Ethernet1/1

  description to MX960-01

  switchport mode trunk

  switchport trunk allowed vlan < range value vlan-id

  channel-group 2 mode active

!

interface Ethernet1/2

  description to MX960-02

  switchport mode trunk

  switchport trunk allowed vlan < range value vlan-id

 channel-group 3 mode active

!

interface Ethernet1/47

  description B2B Nexus-2

  switchport mode fabricpath

  channel-group 1 mode active

!

interface Ethernet1/48

  description B2B Nexus-2

  switchport mode fabricpath

  channel-group 1 mode active