In questo documento metteremo in evidenza una procedura di configurazione OTV per

Architettura di Riferimento:

 

otv design

 

 

 

OTV internal interface:

 

interface port-channel 200

switchport

switchport mode trunk

switchport trunk native vlan 100

switchport trunk allowed vlan 10,12,14,20-30,40-50,70-99,1000

spanning-tree port type normal

mac packet-classify

!

interface  ethernet 3/23

switchport

switchport mode trunk

switchport trunk native vlan 100

switchport trunk allowed vlan 10,12,14,20-30,40-50,70-99,1000

spanning-tree port type normal

channel-group 200 mode active

no shut

!

interface  ethernet 7/23

switchport

switchport mode trunk

switchport trunk native vlan 100

switchport trunk allowed vlan 10,12,14,20-30,40-50,70-99,1000

spanning-tree port type normal

channel-group 200 mode active

no shut

!

 

OTV join interface:

 

interface port-channel 300

mtu 1600

ip address 172.16.1.1/30

ip ospf network point-to-point

ip router ospf 10 area 0.0.0.0

ip igmp version 3

no shut

!

interface  ethernet 4/16

mtu 1600

channel-group 300 mode active

no shut

!

interface  ethernet 5/18

mtu 1600

channel-group 300 mode active

no shut

!

 

OTV overlay interface:

 

interface overlay 1

otv join-interface port-channel 300

otv control-group 239.1.1.1

otv data-group 232.0.0.0/24

otv extend-vlan 10,12,14,20-30,40-50,70-99

no shut

!

 

OTV site vlan:

 

vlan 1000

name otv-site-vlan

otv site-vlan 1000

!

otv site-identifier 0x1

 

 

OTV MULTICAST Enabled transport overlay

 

OTV Edge Devices sono configurati per unirsi ad uno specifico ASM (Any Source Multicast) group; in questo modo ogni OTV edge devices diventa receiver e source multicast traffic;

 

Le interfacce in upstream layer 3 debbono essere configurate in PIM sparse-mode ed ogni device deve specificare il SSM group da usare;

 

Un RP (Rendezvou Point) router deve essere definito (due RP per ridondanza, dove quest’ultima può essere ottenuta usando Anycast RP);

 

 

OTV unicast Enabled transport overlay

 

Nella situazione dove non è possibile avere un Multicast Overlay Transport, è possibile utilizzare un trasporto di tipo unicast-only; la differenza sta che ogni Edge Device deve creare multiple copie di ogni control-plane packet relativo ad ogni edge devices remoto facente parte dello stesso logical overlay interface.

 

Un nuovo concetto di adiancenza è introdotto: OTV adjacency server; ogni OTV device cerca di unirsi ad una specifica logical overlay interface avendo il bisogno di registro verso il server inviando hello message; questi messaggi servono al server per costruire una lista di tutti gli OTV devices che dovranno far parte dello stesso dominio overlay (unicast-replication-list).

 

 

otv unicast overlay

 

 ADJ Server 1

 

otv side-identifier 0x1

otv site-vlan 1000

interface overlay 1

 otv join-interface port-channel 300

 otv adjacency-server unicast-only

 otv extend-vlan 10,12,14,20-30,40-50,70-99

 

 

ADJ Server 2

 

otv side-identifier 0x2

otv site-vlan 1000

interface overlay 1

 otv join-interface port-channel 300

 otv adjacency-server unicast-only

 otv use-adjacency-server 10.1.1.1 unicast-only

 otv extend-vlan 10,12,14,20-30,40-50,70-99

 

 

ADJ Client 1

 

otv side-identifier 0x3

otv site-vlan 1000

interface overlay 1

 otv join-interface port-channel 300

 otv use-adjacency-server 10.1.1.1  10.2.2.2 unicast-only

 otv extend-vlan 10,12,14,20-30,40-50,70-99

!

!

show otv overlay 1