nexus vpc-peerlink and peer-keealive config example

 

ARCHITETTURA DI RIFERIMENTO

 

nexus vpc peerlink keepalive

 

 

 

NEXUS PRIMARY

 

NEXUS SECONDARY 

 feature privilege

cfs ipv4 distribute
cfs eth distribute

feature lacp
feature vpc

!

vrf context management

!

vpc domain 10
peer-switch
role priority 4000
system-priority 4000
peer-keepalive destination 10.1.1.2 source 10.1.1.1

!

interface port-channel10
description to N9K-2
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link

!

interface Ethernet1/1
description to N9K3-2 port eth1/1
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown

!

interface Ethernet1/2
description to N9K3-2 port eth1/1
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown

!

interface mgmt0
vrf member management
ip address 10.1.1.1/30

!

switch-profile < name-profile >
 sync-peers destination 10.1.1.2

 

  feature privilege

cfs ipv4 distribute
cfs eth distribute

feature lacp
feature vpc

!

vrf context management

!

vpc domain 10
peer-switch
role priority 8000
system-priority 4000
peer-keepalive destination 10.1.1.1 source 10.1.1.2

!

interface port-channel10
description to N9K-1
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link

!

interface Ethernet1/1
description to N9K3-1 port eth1/1
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown

!

interface Ethernet1/2
description to N9K3-1 port eth1/1
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown

!

interface mgmt0
vrf member management
ip address 10.1.1.2/30

!

switch-profile < name-profile >
 sync-peers destination 10.1.1.1

   

 

 

VPC TERMINOLOGIA:

 

vpc = è un port-channel tra una coppia di Nexus e qualsiasi altro devices in downstream;

 

vpc domain = è un dominio di cluster tra una coppia di Nexus ognuno dei quali ha un proprio control-plane

 

vpc peer-link = è un link (generalmente costituito da un port-channel con link a 10G) utilizzato per sincronizzare gli stati presenti nella coppia di Nexus; viene utilizzato il protocollo CFS (Cisco Fabric Service) per l'affidabilità di questa sincronizzazione;

 

vpc keepalive = è un link di management (differente rispetto al peer-link) utilizzato per verifica e monitoring dello stato di salute di ciascun Nexus del dominio;

 

vpc member-port = è una porta ethernet appartenente al vpc port-channel;

 

orphan port = è una porta ethernet non appartenente a nessun vpc port-channel (generalmente collegata a terze-parti devices);

 

vpc split-horizon = è attiva la funzionalità di split-horizon per evitare loop tra un vpc (traffico entrante in un determinato port-channel non può uscire dallo stesso port-channel)