Questo documento evidenzia le metodologie di collegamento dei soli Nexus 5000 family in collegamento con i Nexus FEX N2K best-practices cisco

 

I Nexus che supportano enhanced-vpc sono Nexus 5548P, cisco Nexus 5548UP, and cisco Nexus 5596UP devices Cisco NX-OS 5.1(3)N1(1)

I Nexus della famiglia 5010 5020 invece non supportano enhanced-vpc

 

fonte: Cisco System

 

Di seguito una rappresentazione grafica delle architetture possibili:

 

 

1) POD FEX 1x N2K with active-standby dual-homed

 

  • I FEX sono switch cisco gestiti dai loro parent-switch Nexus 5000 (possono essere visti come una estensione modulare dei parent-switch N5K);
  • In questa configurazione il FEX N2K è nello stato Online con il Nexus N5K-1 e rimane nello stato Connected nel N5K-2 perchè è già registrato dal primo
  • La connessione verso il N5K-2 (standby) non è usato per il trasporto del data traffic
  • La transazione da un parent-switc ad un’altro ha una attesa di circa 40 secondi prima che il Fabric Extender (FEX) diventa Online.
  • Per evitare questa situazione possiamo considerare una connessione di tipo active-active con vPC

 

N5K FEX 1

 

2) POD FEX 1x N2K with active-active dual-homed

 

  • In active-active configuration, il FEX N2K è nello stato Online per entrambi I parent-switch N5K.
  • In questa topologia un eventuale failure di un parent-switch non ha effetto sul FEX perchè entrambi i parent-switch peers vPC gestiscono la sua connessione simultaneamente.
  • Requisito prevede che la configurazione FEX N2K sia la stessa (incluso le host interfaces) in entrambi gli switch

 

N5K FEX 2

Esempio Configurazione 

 

interface eth1/1

switchport mode fex-fabric

fex associate 100

!

interface port-channel 100

switchport mode fex-fabric

fex associate 100

vpc 100

 

 

 

3) POD FEX 2x N2K with enhanced vpc

 

  • Questa configurazione con doppio FEX prevede una EvPC capacità, mantenendo la stessa configurazione per entrambi i parent-switch N5K e rilasciando un port-channel per l’nterfaccia di collegamento al server che si cerca di aggregare

 

N5K FEX 3

Esempio di Configurazione

 

interface po30

switchport access vlan 30

!

interface Ethernet 100/1/1

switchport access vlan 30

speed 1000

channel-group 30

!

interface Ethernet 101/1/1

switchport access vlan 30

speed 1000

channel-group 30

!