Configurazione di un tunnel manuale IPV6 tra due routers IPv4 core permettendo lo scambio di routes tra due isole IPv6 LAN remote

 

Architettura di riferimento:

 

tunnel ipv6 slaac

 

 

Attraverso la aut-config slaac dei rispettivi router i PC ottengono la seguente configurazione:

 

PC1:

FastEthernet0 Connection:(default port)

Physical Address................: 00E0.A38C.E7C0

Link-local IPv6 Address.........: FE80::2E0:A3FF:FE8C:E7C0

IPv6 Address....................: 2001:1111:1111:0:2E0:A3FF:FE8C:E7C0/64

Default Gateway.................: FE80::201:42FF:FE40:E801

DNS Servers.....................: ::

DHCPv6 Client DUID..............: 00-01-00-01-2B-0D-C3-EE-00-E0-A3-8C-E7-C0

 

 

PC2:

FastEthernet0 Connection:(default port)

Physical Address................: 00D0.BA17.7988

Link-local IPv6 Address.........: FE80::2D0:BAFF:FE17:7988

IPv6 Address....................: 2001:1111:1111:0:2D0:BAFF:FE17:7988/64

Default Gateway.................: FE80::201:42FF:FE40:E801

DNS Servers.....................: ::

DHCPv6 Client DUID..............: 00-01-00-01-40-77-87-80-00-D0-BA-17-79-88

 

 

PC3:

FastEthernet0 Connection:(default port)

Physical Address................: 0005.5E20.9337

Link-local IPv6 Address.........: FE80::205:5EFF:FE20:9337

IPv6 Address....................: 2003:3333:3333:0:205:5EFF:FE20:9337/64

Default Gateway.................: FE80::201:C9FF:FE77:401

DNS Servers.....................: ::

DHCPv6 IAID.....................: 1731170596

DHCPv6 Client DUID..............: 00-01-00-01-E5-D8-69-80-00-05-5E-20-93-37

 

 

PC4:

FastEthernet0 Connection:(default port)

Physical Address................: 0040.0BA7.5453

Link-local IPv6 Address.........: FE80::240:BFF:FEA7:5453

IPv6 Address....................: 2003:3333:3333:0:240:BFF:FEA7:5453/64

Default Gateway.................: FE80::201:C9FF:FE77:401

DNS Servers.....................: ::

DHCPv6 Client DUID..............: 00-01-00-01-12-A0-3D-A9-00-40-0B-A7-54-53

 

 

 

Configurazione Routers

 

R1:

 

ipv6 unicast-routing

!

interface Tunnel0

no ip address

mtu 1476

ipv6 address 3FFE:B00:C18:1::3/127

tunnel source FastEthernet0/1

tunnel destination 1.1.1.2

tunnel mode ipv6ip

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

ipv6 address 2001:1111:1111::1/64

ipv6 address autoconfig

ipv6 enable

!

interface FastEthernet0/1

ip address 1.1.1.1 255.255.255.252

duplex auto

speed auto

!

router ospf 1

router-id 192.168.1.1

log-adjacency-changes

network 1.1.1.0 0.0.0.3 area 0

!

ipv6 route 2003:3333:3333::/64 3FFE:B00:C18:1::2

 

 

R2:

 

ipv6 unicast-routing

!

interface Tunnel0

no ip address

mtu 1476

ipv6 address 3FFE:B00:C18:1::2/127

tunnel source FastEthernet0/1

tunnel destination 1.1.1.1

tunnel mode ipv6ip

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

ipv6 address 2003:3333:3333::1/64

ipv6 address autoconfig

ipv6 enable

!

interface FastEthernet0/1

ip address 1.1.1.2 255.255.255.252

duplex auto

speed auto

!

router ospf 1

router-id 192.168.2.2

log-adjacency-changes

network 1.1.1.0 0.0.0.3 area 0

!

ipv6 route 2001:1111:1111::/64 3FFE:B00:C18:1::3

!

 

 

VERIFICA:

 

 

R1#sh ipv6 interface tunnel 0

Tunnel0 is up, line protocol is up

IPv6 is enabled, link-local address is FE80::201:C9FF:FE63:1A12

Global unicast address(es):

3FFE:B00:C18:1::3, subnet is 3FFE:B00:C18:1::2/127

Joined group address(es):

FF02::1

FF02::2

FF02::1:FF00:3

FF02::1:FF63:1A12

MTU is 1476 bytes

!

R1#sh ipv6 route

IPv6 Routing Table - 7 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

U - Per-user Static route, M - MIPv6

I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

D - EIGRP, EX - EIGRP external

C 2001:1111:1111::/64 [0/0]

via ::, FastEthernet0/0

L 2001:1111:1111::1/128 [0/0]

via ::, FastEthernet0/0

S 2003:3333:3333::/64 [1/0]

via 3FFE:B00:C18:1::2

C 3FFE:B00:C18:1::2/127 [0/0]

via ::, Tunnel0

L 3FFE:B00:C18:1::3/128 [0/0]

via ::, Tunnel0

C FD11:192:168:1::1/128 [0/0]

via ::, Loopback0

L FF00::/8 [0/0]

via ::, Null0

 

R1#ping ipv6 2003:3333:3333:0:205:5EFF:FE20:9337  # PC3 remote LAN

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2003:3333:3333:0:205:5EFF:FE20:9337, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/2 ms

 

 

 

R2#sh ipv6 interface tunnel 0

Tunnel0 is up, line protocol is up

IPv6 is enabled, link-local address is FE80::290:2BFF:FE42:BB2C

Global unicast address(es):

3FFE:B00:C18:1::2, subnet is 3FFE:B00:C18:1::2/127

Joined group address(es):

FF02::1

FF02::2

FF02::1:FF00:2

FF02::1:FF42:BB2C

MTU is 1476 bytes

!

R2#sh ipv6 route

IPv6 Routing Table - 7 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

U - Per-user Static route, M - MIPv6

I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

D - EIGRP, EX - EIGRP external

S 2001:1111:1111::/64 [1/0]

via 3FFE:B00:C18:1::3

C 2003:3333:3333::/64 [0/0]

via ::, FastEthernet0/0

L 2003:3333:3333::1/128 [0/0]

via ::, FastEthernet0/0

C 3FFE:B00:C18:1::2/127 [0/0]

via ::, Tunnel0

L 3FFE:B00:C18:1::2/128 [0/0]

via ::, Tunnel0

C FD11:192:168:2::2/128 [0/0]

via ::, Loopback0

L FF00::/8 [0/0]

via ::, Null0


!

R2#ping ipv6 2001:1111:1111:0:2E0:A3FF:FE8C:E7C0  # PC1 remote LAN

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001:1111:1111:0:2E0:A3FF:FE8C:E7C0, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/2/12 ms