Architettura di riferimento:
Example Config:
CE1 (Juniper)
root@CE1>; show configuration
## Last commit: 2020-10-21 10:39:13 UTC by root
version 10.1R1.8;
system {
host-name CE1;
root-authentication {
encrypted-password "$1$/ut7rW6z$VA59/unkYFlKp/qNjl2d//"; ## SECRET-DATA
}
}
interfaces {
em0 {
description LAN1;
unit 0 {
family inet {
address 10.10.10.1/24;
}
family inet6 {
address 2001:1111:1111::/64 {
eui-64;
}
}
}
}
em1 {
description to-CE1;
unit 0 {
family inet {
address 10.1.0.0/31;
}
family inet6 {
address fc00::10:1:0:0/127;
}
}
}
}
protocols {
router-advertisement {
interface em0.0 {
prefix 2001:1111:1111::/64;
}
}
}
In formato display set:
set system host-name CE1
set system root-authentication encrypted-password "$1$/ut7rW6z$VA59/unkYFlKp/qNjl2d//"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 description LAN1
set interfaces em0 unit 0 family inet address 10.10.10.1/24
set interfaces em0 unit 0 family inet6 address 2001:1111:1111::/64 eui-64
set interfaces em1 description to-PE1
set interfaces em1 unit 0 family inet address 10.1.0.0/31
set interfaces em1 unit 0 family inet6 address fc00::10:1:0:0/127
set protocols router-advertisement interface em0.0 prefix 2001:1111:1111::/64
root@CE1>; show interfaces em0.0
Logical interface em0.0 (Index 64) (SNMP ifIndex 18)
Flags: SNMP-Traps Encapsulation: ENET2
Input packets : 6
Output packets: 22
Protocol inet, MTU: 1500
Flags: Is-Primary
Addresses, Flags: Is-Default Is-Preferred Is-Primary
Destination: 10.10.10/24, Local: 10.10.10.1, Broadcast: 10.10.10.255
Protocol inet6, MTU: 1500
Flags: Is-Primary
Addresses, Flags: Is-Default Is-Preferred Is-Primary
Destination: 2001:1111:1111::/64,
Local: 2001:1111:1111:0:e2e:49ff:fe62:3600
Addresses, Flags: Is-Preferred
Destination: fe80::/64, Local: fe80::e2e:49ff:fe62:3600
root@CE1>; show ipv6 neighbors
IPv6 Address Linklayer Address State Exp Rtr Secure Interface
2001:1111:1111:0:2050:79ff:fe66:6800
00:50:79:66:68:00 stale 961 no no em0.0
Il PC1 automaticamente avrà la seguente configurazione:
PC1> show
NAME IP/MASK GATEWAY MAC LPORT RHOST:PORT
PC1 10.10.10.10/24 10.10.10.1 00:50:79:66:68:00 20004 127.0.0.1:20005
fe80::250:79ff:fe66:6800/64
2001:1111:1111:0:2050:79ff:fe66:6800/64
PC1> show ip
NAME : PC1[1]
IP/MASK : 10.10.10.10/24
GATEWAY : 10.10.10.1
DNS :
MAC : 00:50:79:66:68:00
LPORT : 20004
RHOST:PORT : 127.0.0.1:20005
MTU: : 1500
PC1> show ipv6
NAME : PC1[1]
LINK-LOCAL SCOPE : fe80::250:79ff:fe66:6800/64
GLOBAL SCOPE : 2001:1111:1111:0:2050:79ff:fe66:6800/64
ROUTER LINK-LAYER : 0c:2e:49:62:36:00
MAC : 00:50:79:66:68:00
LPORT : 20004
PC1> ping 2001:1111:1111:0:e2e:49ff:fe62:3600
2001:1111:1111:0:e2e:49ff:fe62:3600 icmp6_seq=1 ttl=64 time=2.842 ms
2001:1111:1111:0:e2e:49ff:fe62:3600 icmp6_seq=2 ttl=64 time=2.342 ms
2001:1111:1111:0:e2e:49ff:fe62:3600 icmp6_seq=3 ttl=64 time=2.653 ms
2001:1111:1111:0:e2e:49ff:fe62:3600 icmp6_seq=4 ttl=64 time=2.537 ms
2001:1111:1111:0:e2e:49ff:fe62:3600 icmp6_seq=5 ttl=64 time=3.091 ms
PC1> ping 10.10.10.1
84 bytes from 10.10.10.1 icmp_seq=1 ttl=64 time=0.688 ms
84 bytes from 10.10.10.1 icmp_seq=2 ttl=64 time=1.365 ms
84 bytes from 10.10.10.1 icmp_seq=3 ttl=64 time=1.354 ms
84 bytes from 10.10.10.1 icmp_seq=4 ttl=64 time=1.221 ms
84 bytes from 10.10.10.1 icmp_seq=5 ttl=64 time=0.943 ms
^C
PC1>