VPC TERMINOLOGIA:

 

vpc = è un port-channel tra una coppia di Nexus e qualsiasi altro devices in downstream;

 

vpc domain = è un dominio di cluster tra una coppia di Nexus ognuno dei quali ha un proprio control-plane

 

vpc peer-link = è un link (generalmente costituito da un port-channel con link a 10G) utilizzato per sincronizzare gli stati presenti nella coppia di Nexus; viene utilizzato il protocollo CFS (Cisco Fabric Service) per l'affidabilità di questa sincronizzazione;

 

vpc keepalive = è un link di management (differente rispetto al peer-link) utilizzato per verifica e monitoring dello stato di salute di ciascun Nexus del dominio;

 

vpc member-port = è una porta ethernet appartenente al vpc port-channel;

 

orphan port = è una porta ethernet non appartenente a nessun vpc port-channel (generalmente collegata a terze-parti devices);

 

vpc split-horizon = è attiva la funzionalità di split-horizon per evitare loop tra un vpc (traffico entrante in un determinato port-channel non può uscire dallo stesso port-channel) 

 

VPC DESIGN:

 

 

 

Nexus-01# 

feature privilege

cfs ipv4 distribute
cfs eth distribute

feature lacp
feature vpc

!

vpc domain 10
role priority 4000
system-priority 4000
peer-keepalive destination 192.168.1.2 source 192.168.1.1

auto-recovery

ip arp syncronize

!

spanning-tree vlan < range > priority 4096

spanning-tree port type edge bpduguard default
!

interface port-channel10
description to Nexus-02
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link

no shut

!

interface Ethernet1/1
description to Nexus-02
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown

!

interface Ethernet1/2
description to Nexus-02
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown

!

vrf context management

!

interface mgmt0
vrf member management
ip address 192.168.1.1/30

!

switch-profile Nexus
sync-peers destination 192.168.1.2

 

 

VERIFICA VPC NEXUS-01

 

NEXUS-01# show vpc

Legend:

                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 10 

Peer status                       : peer adjacency formed ok     

vPC keep-alive status             : peer is alive                

Configuration consistency status  : success

Per-vlan consistency status       : success                      

Type-2 consistency status         : success

vPC role                          : primary, operational secondary

Number of vPCs configured         : 3  

Peer Gateway                      : Disabled

Peer gateway excluded VLANs       : -

Dual-active excluded VLANs        : -

Graceful Consistency Check        : Enabled

Auto-recovery status              : Enabled (timeout = 240 seconds)

 

vPC Peer-link status

---------------------------------------------------------------------

id   Port   Status Active vlans   

--   ----   ------ --------------------------------------------------

1    Po10   up     < range >                                    

 

 

vPC status

----------------------------------------------------------------------

id   Port   Status Consistency Reason                     Active vlans

--   ----   ------ ----------- ------                     ------------

11   Po11   up     success     success                    < range >        

                                                                         

312  Po312  up     success     success                    < range >    

                                                                         

313  Po313  up     success     success                    < range >    

 

 

 

 

Nexus-02# 

feature privilege

cfs ipv4 distribute
cfs eth distribute

feature lacp
feature vpc

!

vpc domain 10
role priority 8000
system-priority 4000
peer-keepalive destination 192.168.1.1 source 192.168.1.2

auto-recovery

ip arp syncronize

!

spanning-tree vlan < range > priority 4096

spanning-tree port type edge bpduguard default
!

interface port-channel10
description to Nexus-01
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link

no shut

!

interface Ethernet1/1
description to Nexus-01
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown

!

interface Ethernet1/2
description to Nexus-01
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown

!

vrf context management

!

interface mgmt0
vrf member management
ip address 192.168.1.2/30

!

switch-profile Nexus
sync-peers destination 192.168.1.1

 

 

VERIFICA VPC NEXUS-02

 

NEXUS-02# show vpc

Legend:

                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 10 

Peer status                       : peer adjacency formed ok     

vPC keep-alive status             : peer is alive                

Configuration consistency status  : success

Per-vlan consistency status       : success                      

Type-2 consistency status         : success

vPC role                          : secondary, operational primary

Number of vPCs configured         : 3  

Peer Gateway                      : Disabled

Peer gateway excluded VLANs       : -

Dual-active excluded VLANs        : -

Graceful Consistency Check        : Enabled

Auto-recovery status              : Enabled (timeout = 240 seconds)

 

vPC Peer-link status

---------------------------------------------------------------------

id   Port   Status Active vlans   

--   ----   ------ --------------------------------------------------

1    Po10   up     < range >                                    

 

 

vPC status

----------------------------------------------------------------------

id   Port   Status Consistency Reason                     Active vlans

--   ----   ------ ----------- ------                     ------------

11   Po11   up     success     success                    < range >        

                                                                         

312  Po312  up     success     success                    < range >    

                                                                         

313  Po313  up     success     success                    < range >